No announcement yet.

Mouse wheel and other interfacing issues in DC8.15

  • Filter
  • Time
  • Show
Clear All
new posts

  • Mouse wheel and other interfacing issues in DC8.15

    Howdy everyone,

    I noticed some "interfacing" issues in DC8.15 that are not present in DC7, which I also use. They're present in my old XP computer as well as a new Win8 machine built by Tracer (thanks, Curtis!) so I think it's in the program.

    1. Sometimes I use the mouse wheel to change the values of the filter sliders. In DC7, the wheel works perfectly in both directions, up and down all the sliders, but in DC8, the wheel only works in one direction. That is, it moves the slider in the down direction to lower the value (on most sliders), but more accurately, it will only lower the absolute value of the slider. For example, in the Dynamics Processor, the wheel lowers the Ratio values (which are all positive) so it moves the slider down, but it actually raises the Threshold values (which are all negative) so it moves the slider up.

    I've tried several different mice with the same result. Adjusting pointer speed and wheel scrolling has no effect. Using the keyboard arrow keys instead of the mouse wheel works perfectly fine on all sliders, so that's an alternative, but the mouse is easier for me. Checking or unchecking Use Mouse Wheel for Zooming in Preferences has no effect. BTW, unchecking Zooming works to change the vertical scale sliders (display gain) for the source and destination on the right hand side of the display via the mouse wheel (moves both up and down) but the rate of change is so sluggish that it's useless (>10x the wheel spins required in DC8 as DC7). Also the wheel has no effect on the respective adjacent sliders (the Offset control and/or the Spectrogram left-hand slider). Again, these issues are in DC8, but not DC7.

    2. The "A" hot key does not work to highlight the displayed area - nothing happens. Double clicking can work to highlight, except if markers are present, in which case, the area between the markers is highlighted, not just the displayed section as I wanted. Control-A does work, but that highlights the entire file. Again, the "A" key works OK in DC7.

    3. This only applies to the Virtual Valve filter, but after a selection is made in the drop-down menu, the preset name appears OK, but as soon as Preview is clicked, the name disappears (goes blank). All the slider values are OK, but you can't see the name of the preset. Again, this doesn't happen in DC7.

    4. In the Multifilter, the space bar works to start and stop Preview but in Live Preview, it will only stop, not start. The space bar also works OK in all the other filters to start and stop Preview. Again, not a DC7 issue.

    Curtis verified several of these issues and I wondered if others have also noticed them. I'd appreciate some investigation. Thanks, everyone!

    Johnny Z

  • #2

    Thanks - we will look into these.

    "Who put orange juice in my orange juice?" - - - William Claude Dukenfield